Adb on Mac cannot detect Moto G device


#1

I just purchased a Verizon Moto G (Android 4.3) to use for on-device Android testing. However, when I connect it to my 2011 MacBook Pro (running Lion), it does not show up in adb. I tried both running adb devices and using DDMS in Eclipse, neither of which showed any device.

I enabled USB debugging and I know that my cable works because when I set the USB computer connection to ‘Camera’, iPhoto launches and connects to the phone just fine. I also downloaded Android File Transfer, which also seems to connect.

I don’t really know what other information would be helpful, and I’ve spent a lot of time looking for a solution to no avail. Let me know if I can add any information that would be useful.


#2

In case anyone else has this problem, this solved it for me:

intohand.com/post.php?s=2011-02- … ing-on-mac

It turns out that even though I hadn’t installed EasyTether on my current device, the drivers were still on my computer


#3

I had the same problem, but did not have EasyTether installed.

Seems obvious, but you have to configure your device for USB debugging before it will show up in DDMS. That means that in Eclipse (or ADT), you won’t see your device in DDMS as the section “Connecting Your Device” describes.

So, to fix, you need to follow the steps in “Configuring your device for development” before following the steps in “Connecting your device”. That will involve enabling the Developer menu in your devices’ settings, and ticking the USB debugging device in the same Developer menu.

I’m not sure if this is an issue with 4.3 (which the G shipped with) as it updated to 4.4 before I plugged it in.


#4

ADB wasnt working on my MacBook either, however got it resolved using EasyTether.

Arjun Dixit
showbox.onl mobdro.one


#5

Hello,

Make sure you are using the latest version of Android debug bridge.

Check here, specially 5.2

esausilva.com/2010/10/02/how-to-set-up-adb-android-debug-bridge-in-mac-osx/

Also make sure you have your phone plugged in and have USB Debugging turned on (Settings > Applications > Development) In Android 4.2.x and up Developer Options is hidden, to make it visible, do the following Tap seven times in Build Number: Settings > About Phone > Build Number You will get a message saying you have enabled Developer Options or something like that, go back to Settings and you will see Developer Options in there.

Adrian Gates
Sr. Developer - Apps4Rent - Hosting Provider


#6

I had a similar issue, yet did not have EasyTether introduced.

Appears glaringly evident, however you need to arrange your gadget for USB investigating before it will appear in DDMS. That implies that in Eclipse (or ADT), you won’t see your gadget in DDMS as the segment “Interfacing Your Device” depicts.

In this way, to settle, you have to take after the means in “Arranging your gadget for advancement” before following the means in “Associating your gadget”. That will include empowering the Developer menu in your gadgets’ settings, and ticking the USB investigating gadget in a similar Developer menu.

Regards,

Terrarium tv for macbook air.

Terrarium tv for macbook mini.


#7

Shows up extremely apparent, anyway you have to orchestrate your contraption for USB exploring before it will show up in DDMS. That suggests that in Eclipse (or ADT), you won’t see your contraption in DDMS as the section “Interfacing Your Device” delineates.

Regards,

http://androidpcapps.com/mobdro-channels-list-updated-guide-2018

http://androidpcapps.com/mobdro-for-pc-download-install-windows-10-7-8-mac-laptop/


#8

ADB wasnt working on my MacBook either, however got it resolved using EasyTether.

Regards,

http://redboxtvdownloadapp.com

http://redboxtvdownloadapp.com/redbox-tv-firestick-amazon-tv


#9

Hello Hi Decent Awesome Article,

Adb on Mac is ea silly detect, The way is kindly change our latest Android version after detect the adb.

Thanks!

TVTap APK for mobile


#10

Hai dear,

adb for mac is really easy…

Thanks,

http://flipacliponline.com/flipaclip-cartoon-animation-apk