App Icon is 57x57 but should be 58x58


#1

Running Xcode 5.0.1 and iOS 6.1 on iPhone
dragged Icon from solution files into the app Icon area and now get compiler warnings, cautions, and it won’t build
any ideas?
thanks
Mike

warning: Ambiguous Content: AppIcon.appiconset/Icon.png is 57x57 but should be 58x58.

The app icon set named “AppIcon” did not have any applicable content.

AppIcon.appiconset/Icon.png is 57x57 but should be 58x58.


#2

Same issue here. I’ve tried toying around with it quite a bit. Anyone else find a solution? Meanwhile, the search continues.


#3

Is it simply a case of you adding an icon image of size 57x57, whereas it should be 58x58, therefore Xcode is informing you of this?

https://developer.apple.com/library/ios/documentation/userexperience/conceptual/MobileHIG/IconMatrix.html


#4

No place to add it? Behold:


#5

Delete AppIcon from the list, then tap on the + button at the bottom and choose “New App Icon”. I believe this will then show the correct sizes.


#6

Yay! That worked! Thank you so very much. On to chapter 2. :sunglasses:


#7

Hey ericksonstudio, can you kindly brief the solution in case you don’t mind as faced the same issue earlier too.

With Regards,
Xovo larjem https://8ballpool.onl/
https://googlehangouts.ooo/
https://omegle.onl/