Appcompat_v7 error and not generating R.java


#1

I wanted to share a problem I encountered and how to fix it:

When creating the application per the book I kept getting errors as soon as the new application wizard was finished. More specifically, an “appcompat_v7” folder was being created above the GeoQuiz folder with errors. This also prevented the R.java file from being created under GeoQuiz/gen/.

Here is the fix:
When going through the wizard, select the minimum required SDK as API 14 instead of API 8 (see pg 3 of book).

Here is a link to the thread that led me to the solution:
stackoverflow.com/questions/2237 … id-project

Hope this helps someone.