assetTypeButton fills entire View


#1

The assetTypeButton fills my entire ItemDetailView. When I want to add a new possession, the navigationItem with the Cancel and Done buttons is shown, and the rest of the view is filled by the assetTypeButton.

Did I miss something there? A connection during the creation of the button? This looks like a stupid mistake to me but I’m kinda lost.


#2

I had exactly the same problem. After I had messed about with it for a while (deleting it and redoing it a number of times) I noticed that the “view” outlet in the file owner was not connected. I did the control-drag from the ‘view outlet’ of the file owner to the main window and that seemed to fix the problem.
Hope this helps.


#3

Woohoo, it works! I did the coding for the chapter again and it worked out of the box. Looks like I missed something the first time. The view connection in the file’s owner was present as well.

When I was messing around with the connections to fix the button problem, things only got worse until the application did crash every time. I suspect that the control-dragging from a control to the header file generates some memory management stuff in the implementation file as well, and these residues killed the app after I removed the control. At one point, [assetTypeButton release] was called twice in ItemDetailViewController.dealloc.

Oh well, it works now, so thanks for your suggestion!