Bad readSession error if VC set to be Retina 4 Full Screen


#1

Hey guys:

I am getting this error when trying to work on the project from the Chapter 5 (MapKit and Text Input) in the book (3 rd edition):
: ImageIO: CGImageReadSessionGetCachedImageBlockData *** CGImageReadSessionGetCachedImageBlockData: bad readSession [0x98566c0]

OSX v10.8.2
rMBP @2.3GHz, 8GB, SSD256GB.
xcode 4.5.2

I’ve followed all steps from the book.

Getting the error when try to run the project with the simulator if WhereamiViewController size is set to “Retina 4 Full Screen”. No errors if VC size is set to “Retina 3.5 Full Screen”.

I even ran system check for any memory issues - everything is fine with my machine …

Any idea why this is happening?

Tnx


#2

Hi,

I’m getting the exact same error. I have no clue, what the problem is, but I seem to get it with all simulator configurations. Not sure if there is a connection between those issues, but when I push the “Done” button, my app crashes. The message I get is:

2012-11-15 11:06:07.255 Whereami[3184:c07] *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘Invalid Region <center:+37.78583400, -122.40641700 span:+250.00000000, +250.00000000>’
*** First throw call stack:
(0x189a012 0x125fe7e 0x1922fb1 0x1b0cd 0x1b246 0x28e2 0x2bb3 0x109cce 0x10928f 0x107315 0x102ac5 0x1859920 0x181cd31 0x1840c51 0x183ff44 0x183fe1b 0x1cc57e3 0x1cc5668 0x1a765c 0x200d 0x1f35 0x1)

Can’t see anything wrong regarding the region, so maybe a consequence of the error before?

Thanks,
Oli


#3

I am having the same problem. Any clues on how to fix this?


#4

Have you tried changing the simulator device type? Is your Xcode outdated? I’m not seeing the same error…


#5

Make sure to set your outlets correctly. Go to your xib or storyboard file and right click on the MKMapView. Drag the Referencing Outlet to the Files Owner and select the variable you assigned to the MKMapView in your .h file.

I had the same issue and was able to resolve it this way.