Before reading the book , I need advice


#1

Hello,
The same question for the IOS book , I want to read this book of Objective-C , but
1/ I am using Mac os montain lion 10.8 , is it okay ?
2/ I want to use Xcode 4.4 , is it okay ? Or should I install another version ? ( for now I didn’t install any version of Xcode )