BNRImageStore setImage


#1

p.248f “setImage” seems a bad choice for the method name here, since this is not an accessor of a property called “image”.

Suggest using “storeImage” instead; so it is clear that this method is not overriding a setter.


#2

setImage: would be a bad choice.

It is setImage:forKey:, though. Totally different method name. See NSDictionary’s setObject:forKey: or NSObject’s setValue:forKey:.