Build and debug brings up blank simulator


#1

Going through chapter 1, I’ve followed the instructions exactly and checked all syntax. It compiles fine and loads an iPhone simulator with a completely blank white screen. The buttons and labels created in the “Using Interface Builder” section don’t show up in the Simulator. I’ve checked all the files three times line for line against the book and ensured the connections in the Connection Panel match the example image in the book.

I can’t figure out what I’m doing wrong. Any idea what I might have omitted?

James Vitale


#2

You may have disconnected the application delegate. Check the connections of the File’s Owner, make sure the delegate outlet is connected to the instance of QuizAppDelegate.

Make sure that QuizAppDelegate’s window outlet is connected to the Window object in the Doc Window.

Make sure that [window makeKeyAndVisible]; is somewhere within application:didFinishLaunchingWithOptions:.

Make sure that application:didFinishLaunchingWithOptions: is being called by putting a NSLog(@“hi”); in the method body.


#3

Hi all,

I too have “to the best of my ability” followed all the the instructions in Chapter 1 exactly and I’ve gone through JoeConways list of possible fixes, but I’m still running into the “blank simulator”.

I just purchased the IMac I’m using to develop, it’s running Xcode 4.0 (I believe).

I tried the [color=#008000]NSLog(@“hi”);[/color] and it worked (I could see the message in the console). I even tried dropping a new label, totally unrelated to the others and it doesn’t display either.

Any ideas/hints? I’m really excited about programming on the IPhone, I’m hoping to get past the 1st Chapter soon!

Thanks,

Matt


#4

Try creating a new project, then building and running before you type in any code. Is the screen white on the simulator?


#5

When I build and run a fresh project, the screen is grey :confused: I’m lost.
edit: Can I zip up my quiz project and send it to you Joe?


#6

Yes, with a totally new project, I get a blank white screen on the simulator. I’ve even tried another beginner project (from a different website) where the only “thing” that happens is the screen is purple instead of white. That works.

Any other suggestions?

Thanks again!


#7

Good news, I finally got it to work! I believe the issue I was running into had to do with a difference in behavior between Visual Studio and Xcode that I wasn’t anticipating. When I built/ran a VS project, it automatically saved my changes. It appears the same thing wasn’t happening in Xcode. I imagine there’s setting somewhere to change that. Thanks again for your help Joe!