Build works, but maps are not showing


#1

Hi,

I am using XCode 4.3.2, IPhone Simulator 5.1, and I’m trying to get the MapKit code to work. I have made all the interface connections and followed the coding instructions up to page 109 of the book (3rd edition). It builds fine without any errors, but when I run it on the IPhone simulator, it just shows the input box but no map - instead, the background is greyed out with a grid where the map should be. I have simulated the location by selecting it from the drop down, but no joy.

I have now downloaded the code example from this site to see where my code is going wrong, but that also gives the same result:

I’m confused as why they are both failing the exact same way. Do I need to be connected to the internet for it to download the maps or something? Or maybe there’s an extra library that I need to add to the app?

Any help or suggestions would be much appreciated!

Many thanks,

Nick


#2

Yes, an internet connection is required to download map data from Google.


#3

Ah, ok thanks, that explains it.

My wi-fi dongle is not working at the moment, so that’s why it’s not downloading. It does not make any mention of needing an active internet connection in the book, so I wasn’t aware that would be a problem.

Cheers,

Nick