Cannot create BOOL from object (+1)


#1

The application worked perfectly and I tried to make the modification with the CarArrayController.
Since this modification, I get the error message :

2013-09-04 14:43:32.877 CarLot[18620:303] Cannot create BOOL from object (
) of class _NSControllerArrayProxy
2013-09-04 14:43:32.895 CarLot[18620:303] Cannot create BOOL from object (
) of class _NSControllerArrayProxy

When I launch the application, and nothing appear (no window).

I got the solution from the site, and It runs perfectly.
I compare between the both, correct some mistake, but the errors remain.

I already read about this subject on the forum, and tried to clean, erase old data and rebuild but without success.
I would appreciate any idea.

But more, I will be very enjoyed if someone can explain me how to debug such “magic”, that are surely TOO magic (at least for me, cause I don’t like when the only solution for any error is to rebuild everytime, everything from scratch)

Many thanks to those who can help.


#2

I had the same problem as you. Cannot create BOOL. Drove me mad. Rewrote the code three times, still the same problem.
The fourth time I realized that I didn’t bind the array controller’s managedObjectsContext to the File’s Owner’s managedObjectsContext under PARAMETERS. It doesn’t say explicitly in the text BUT the from Figure 11.3 it is clear.
Instead I did the binding under AVAILABILITY.

As soon as I changed this everything worked as it should….embarrassing… :blush: