Cannot create the HomepwnerItemCell connections


#1

I’m using Xcode 4.33
Whey I control click from the subviews (UIImage, UILabel, et al) to the .h file, I try to create the outlet and I keep getting a red warning message: Could not insert new outlet connection…
I took care to change the class to HomepwnerItemCell and so I’m not sure why it won’t’ work. Any ideas?


#2

I’m experiencing exactly the same problem.


#3

I found out what I’d done wrong.
I’d managed to drag the UITableCellView on top of the default UIView in the XIB file.
I deleted the contents of the XIB file, including the UIView, then started again.
This time it worked!
Doh!
Hope it works for you!


#4

I tried that, but there’s something I’m not doing correctly. I have a blank XIB. I dragged on a UITableViewCell and then dragged on my image and labels. Still, when I control click on my image and drag to the .h file, I’m getting that same error message as before. Am I supposed to drag a UIView onto the XIB before I add the UITableViewCell? I tried that, too, and it didn’t seem to matter.


#5

Does anyone have any idea why this is happening?


#6

I had the same problem. I found the solution here ebohling.tumblr.com/

  1. Close your project.
  2. Go to the ~/Library/Developer/XCode/DerivedData folder and REMOVE all subfolders there referencing the project you are working on.
  3. Open your project in XCode. The problem should be fixed now.