Can't add a localized XIB


#1

I am running Mountain Lion and XCode 4.4 - more recent than the book. When I enabled localization for the XIB file in the homepwner project, it only gave me the option of English in the popup. I selected this, and in the utilities view it shows English, but there is no “+” button to add another language. Did XCode change or is there something wrong with my project or system setup? Any suggestions on how to create another instance of the XIB?

Thx


#2

Of course two minutes after posting, a little more googling led me to the answer - you have to add a language in the project settings first:

stackoverflow.com/questions/1159 … n-settings


#3

Yes, found similar at
stackoverflow.com/questions/1183 … my-ios-app

In my opinion, this seems to be an error in the book, maybe the authors forgot to mention that. It seems that we first need to specify which languages can be localized for the project, and then for individual resources, you may choose from those languages.


#4

Thanks for posting links - saved me a ton of headache!


#5

[quote=“nishant2200”]Yes, found similar at
stackoverflow.com/questions/1183 … my-ios-app

In my opinion, this seems to be an error in the book, maybe the authors forgot to mention that. It seems that we first need to specify which languages can be localized for the project, and then for individual resources, you may choose from those languages.[/quote]

not an error in the book. xcode changes all the time.