Can't get emulator/device working


#1

I have an android device; a Samsung galaxy S5, but Android studio doesn’t seem to recognize it. Here are the steps I did:

  1. Plugged my device into computer
  2. Clicked the Android Device Monitor icon in the top right
    –>My device did not show up on the device side bar so:
  3. I went to the arrow and did ‘reset adb’, still nothing.

I followed the steps in the book exactly and they said if the device doesn’t show up after I hit reset adb go to the forums, so here I am! Note that I am not using Eclipse I am using Android Studio.

I also have trouble getting the Emulator up. I followed the steps in the book to set up the Emulator however, I had to choose different options for my Emulator because the options the book told me to select I did not have. The emulator seems to appear when I run the project however all it shows is “android” across a black screen. I’ve tried clicking buttons but it doesn’t do anything. Since I have an actual device I would think getting the device working would be more beneficial to me. However, again neither works, help please!

Thank you.
-Matt

*EDIT:
I just noticed an error in my Android Device Manager Console, it says:

[2014-07-19 19:46:22 - DeviceMonitor] Adb connection Error:An existing connection was forcibly closed by the remote host
[2014-07-19 19:46:23 - DeviceMonitor] Connection attempts: 1


#2

I now got my device to show up on the devices table. I didn’t configure my device for development. However, i am now getting an error when I try to run Geoquiz on my phone:

pkg: /data/local/tmp/com.example.matt.geoquiz
Failure [INSTALL_FAILED_OLDER_SDK]


#3

It seems that your target API level is lower than the phone, try using higher API level when creating the Android project.


#4

Open your SDK manager and check you have installed
Google USB Driver
Intel x86 Emulator Acceleration(if your using Intel instead of ARM)