Can't run on iOS simulator


#1

My Xcode project does not show the iPhone 5.0 Simulator as an option like Figure 27.6, it only shows iOS Device. How do I change this to run on the simulator? Thanks.


#2

If you click on iOS Device, are you not presented with iPhone and iPad simulator options?

Nick
http://myfirstiphoneapp.co.uk
http://easyintervalsapp.co.uk


#3

No, that was what I had expected as well. The Supported Platforms under the Project Targets shows “iphonesimulator iphoneos” too. I’ve also tried to manage schemes, and create a new scheme but that does not resolve the issue either.


#4

Do you have the simulator installed (have you run projects on it before)?


#5

I thought I did, I just downloaded XCode 4.2 for now leopard, shouldn’t it come with it?
I searched for the path and found it here:
/Platforms/iPhoneSimulator.platform/Developer/Applications/iOS Simulator
so I’m pretty sure I have it. I don’t want to use my device every time I’m testing. Any help?


#6

This is a strange one. Are you able to supply some screenshots from Xcode?

At I guess I would say of TARGETS/Summary, and a screenshot from when you click on the “Scheme” bar next to the Run/Stop buttons at the top of Xcode.

If you need to, you can email them to me at: admin at myfirstiphoneapp dot co dot uk

Nick


#7

Thanks fujilla and all. I think I figured out what the issue was. First, I reinstalled my version of Xcode (4.2 for snow leopard) which didn’t fix the issue outright. I then poured over the build settings and in the deployment section of the build settings the “Targeted Device Family” was set to iPhone only. Once I changed that to iPhone/iPad the option to select the simulator was available for me for running and debugging. Not sure if this is a common occurrence for newbies but that solved it.

F.Y.I.
I’ve graduated to the iOS Programming BNR guide 3rd edition!! Love these books!!