Careful Autolayout


#1

I could not get to play with the springs and struts in the size inspector.
This is the latest addition in Lion(correct me if I am wrong) and I do not know for your case but in my case it was there by default.

  1. select the nib/xib file and go to File inspector.
  2. in the Interface Builder Document section uncheck Use Autolayout

Hope it helps some ‘unlucky’ folks like me.


#2

Thanks for that tip. I couldn’t see the springs either until I unchecked Auto layout too, which appears to be the default setting now of Xcode 4.3.


#3

I was wondering the same thing (Xcode 4.3.2). Thanks for the handy tip!


#4

One word:

THANKS!! :bulb:


#5

Same here, thanks :slight_smile:


#6

Remember to check the errata, this is documented in there (may not have been when the original notes were written, but it definitely is now).