Debugger: address of locationManager remains 0x0


#1


#2

I had the same problem. I’m using Xcode 4.3.1 on Lion, on a pretty old macbook pro.


#3

It’s probably that this is a bug with LLDB, the new debugger Apple is working on. I’ve never seen LLDB actually work.

You can change back to GDB by holding down option when you run, selecting the “Run (AppName).app” row, then select the Info tab, and change the debugger popup to “GDB”.


#4

I had this issue too - using Xcode 4.5 and ML (10.8.2)

Changing the debugger to GDB from LLDB worked.

Question: When we leave this book and start working on our own projects - which debugger is best to use?

(Also, what’s the difference between the two? )


#5

I had this same problem, by default it seems that the selected debugger is “LLDB”.

Changing the debugger to “GDB” worked, I now see the desired result as described in the book.

Thank goodness for this forum, and all who attend.

BTW I running Mac OS X version 10.7.3 on a mac book air, and using Xcode 4.3.1


#6

Hey all,

I did not work to me even after changing the Debugger to GDB , i get in the console only this:
“This GDB was configured as “x86_64-apple-darwin”.sharedlibrary apply-load-rules all
Attaching to process 804.”

Also changed the location to London etc… and no change on the console.

Running at: Mac OS 10.7.5 , xCode 4.5.2 , iPhone 6 Simulator

Solved:
The problem was with the delegate , need to change it to this:
-(void)locationManager:(CLLocationManager *)manager didUpdateLocations:(NSArray *)newLocation