Debugger not hitting breakpoints


#1

I can’t seem to get the debugger to come up, regardless of whether I’m using the emulator or a device. I couldn’t get the Stack Trace to jump to code on the fatal error on P 76, but when I put in the Log.d statement, I could. But I’ve been trying to set breakpoints, and Eclipse just seems to ignore them. I launch using the debugger, I’ve tried re-launching from within the debugger, and several other things which at the moment I’ve forgotten. No amount of playing around seems to make the debugger come up.

The devices window shows GeoQuiz as using port 8605, and the app runs in the emulator OK. It just never hits breakpoints. I’ve even tried setting the breakpoints at several different places in the code. When I put a log statement in, that comes up on the LogCat. But when I put a breakpoint on the next statement, it just doesn’t hit it.

Any suggestions?


#2

Well, I searched around on the Web for an answer, and I found it here: stackoverflow.com/questions/4617 … -work?rq=1

I had tried several other suggestions from the Web, but this one worked.