update: Mistake found. No error as original post suggested.
Thanks for keeping an eye out for us, but I believe that addCrime is correct. I can’t find any definition for an add(Crime) method in our book source.
Oh, you’re so right. I accidentally named the method “add()” instead of “addCrime()”. Good catch!
Hah - love the edit to the topic title.