Downloaded version doesn't save state


#1

I ran into some weird behavior halfway through Chapter 15, probably a typo by myself, or missed connection. So copied over the Chapter 14 downloaded solution. Also deleted the ~/Library/Application Support/iPhone Simulator/6.1/Applications/[UUID] directory (hereafter UUID directory) for Homepwner.

Thought this would get a fresh start with this version, but it does not save the state into an items.archive file. Strangely, the image copies are saved into the UUID directory. But when quitting and relaunching the simulator, the old items do not reappear.

Same behavior with the Chapter 15 solution, which leaves me at the least frustrated that I have to re-populate every time I run the app. And worrying that further development will start breaking worse. Any suggestions?


#2

OK, progress. If you quit the simulator rather than exiting the app via the Home button, no state is saved. But if you click the Home button, then quit the simulator, state is saved.

I think the book’s terminology (“Take some photos…, then exit and relaunch the application”, p.308) is ambiguous: I took “application” to mean the simulator, not the simulated.

Notwithstanding my belief that this is as good a programming book as I have ever read!