Empty application template and prefix class


Hi guys I just started the book and I’m loosing my mind from the 1st chapter already !
in the new Xcode 6.4 I can’t find the empty application template and I tried to download it and add it but when I used it it still comes with NO class prefix and it seems that it’s messing up my code writing -which I don’t understand most if it now!- and the app won’t built
please help me! :frowning:((


You will have a much smoother ride if you use the Version of Xcode for which the book was written. By trying to use the latest and greatest version of Xcode you are only making it harder for yourself.


hi thanks for your reply ! :slight_smile:)

forgive my dumb question though

how can I do that? i checked app store and apparently i can only get the latest version from there


You should be able to download previous versions of Xcode from Apple Developer site. For this, you need to sign in with your Apple ID.


Hey thanks for your help!
I did find it :slight_smile:


Did Xcode 5 work on your current OS? I tried downloading it but it won’t be able to run on El Capitan. Does anybody know of a solution to this?


I just did it for Xcode 7. Once you know where to go to it is simple (as always in life)

Re: Using Xcode 6 with the 4th Edition book

Postby KarimAzzouz » Wed Oct 08, 2014 8:52 pm
Regarding the empty application template disappearing in Xcode6 , I found a workaround :

Download the empty application template from here : cl.ly/401z1t1R1b3Z

then copy over the contents of the zip file to here : {Xcode.app}/Contents/Developer/Platforms/iPhoneOS.platform/Developer/Library/Xcode/Templates/Project Templates/iOS/Application/

This worked for me :smiley:

Credit goes to reddit post : reddit.com/r/iOSProgramming/ … on_option/


it is easy with 3 steps:

  1. create an Single View Application

  2. remove files: Main.storyboard, LaunchScreen.xib
    and remove Info.plist entries: “Main storyboard file base name”, “Launch screen interface file base name”

  3. copy code from page 22 (method application: didFinishLaunchingWithOptions:)