Error: Open Failed


#1

Oh boy.

I was looking forward to seeing the new-and-improved memory management in action, but I noticed some warnings in itemDetailViewController.m concerning a few of the possession properties. No big deal. It looks like the data types of the properties in the data model file and the data types in the possession.h file were different, so I made sure they were correct and matching data types. After that I ran the program on the iOS Simulator and I got this error:

2012-03-20 17:32:30.484 Homepwner[7303:10103] application:didFinishLaunchingWithOptions: 2012-03-20 17:32:30.511 Homepwner[7303:10103] *** Terminating app due to uncaught exception 'Open Failed', reason: 'Reason: The operation couldn't be completed. (Cocoa error 134100.)' *** First throw call stack: (0x12c4022 0x1775cd6 0x126ca48 0x126c9b9 0x41e9 0x3f98 0x3331 0x4db06b 0x4dd862 0x38b66d 0x38b167 0x2c0e 0x3c638f 0x3c65eb 0x3d6ff1 0x3d785f 0x3d521f 0x3ebdf1 0x3ebe0d 0x3ebea9 0x32a6f5 0x32a73c 0x2fb596 0x2fc274 0x30b183 0x30bc38 0x2ff634 0x1fc5ef5 0x1298195 0x11fcff2 0x11fb8da 0x11fad84 0x11fac9b 0x2fbc65 0x2fd626 0x22e2 0x2255) terminate called throwing an exception(lldb)

What’s going on here? How do I get Homepwner up and running again?


#2

Hi,

First thing I’d try would be deleting the app from the simulator.
I.e press and hold until the icons start dancing and then press the X

Then rebuild and see if that’s fixed it.

You get this when the model is out of step with the code/data

HTH
Gareth


#3

This worked!
Thank you.


#4

I also have the same problem. I can not figure out the problem with the method above,although I have checked the code twice.Does someone have time to have a look at my code?

2012-11-14 23:11:49.757 Homepwner[8999:c07] *** Terminating app due to uncaught exception 'Open failed', reason: 'Reason: The operation couldn’t be completed. (Cocoa error 512.)' *** First throw call stack: (0x15bd012 0x13e2e7e 0x15bcdeb 0x3382 0x3108 0x2981 0x50e6e8 0x5113c4 0x3d5fa2 0x3d592c 0x87144e4 0x289e 0x40d753 0x40da7b 0x4235bd 0x423eab 0x423fc9 0x424055 0x5293ab 0x37a92d 0x13f66b0 0x2edcfc0 0x2ed133c 0x2edceaf 0x4198cd 0x3621a6 0x360cbf 0x360bd9 0x35fe34 0x35fc6e 0x360a29 0x363922 0x40dfec 0x35abc4 0x35b311 0x2435 0x3277b7 0x327da7 0x328fab 0x33a315 0x33b24b 0x32ccf8 0x240adf9 0x240aad0 0x1532bf5 0x1532962 0x1563bb6 0x1562f44 0x1562e1b 0x3287da 0x32a65c 0x231d 0x2255) libc++abi.dylib: terminate called throwing an exception