Error running ibtool


#1

I’m running xcode on lion, so don’t know if there’s any quirks with this configuration.

I’m wondering about the parameters for ibtool. Here’s the command I used adjusted for my directory configuration and the error I got.

ibtool --import-strings-file ~/Desktop/DetailViewController.strings --write ../es.lproj/Homepwner.xib ../en.lprog/Homepwner.xib<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>com.apple.ibtool.errors</key> <array> <dict> <key>description</key> <string>Interface Builder could not open the document "Homepwner.xib" because it does not exist.</string> </dict> </array> </dict> </plist>
Now I ran the command from within the en.lprog directory, so don’t know if that was issue. I’m wondering though is Homepwner.xib correct in this case, shouldn’t it be creating a DetailViewController.xib file?

So, what did I miss?


#2

You should be writing DetailViewController.xib. Homepwner.xib isn’t a file in this project.


#3

In the book on page 345 it has

ibtool --import-strings-file ~/Desktop/DetailViewController.strings --write
/iphone/Homepwner/Homepwner/es.lproj/Homepwner.xib
/iphone/Homepwner/Homepwner/en.lproj/Homepwner.xib

so it should really be:
ibtool --import-strings-file ~/Desktop/DetailViewController.strings --write
/iphone/Homepwner/Homepwner/es.lproj/DetailViewController.xib
/iphone/Homepwner/Homepwner/en.lproj/DetailViewController.xib

Correct?


#4

Yup, you are totally right, the book has an error. Thanks for finding that… did changing the text to DetailViewController.xib work?


#5

Yeah Joe, changing that worked as described. I thought it was wrong in the book, but no one else seemed to post about it, or seemed to notice it


#6

Well, thank you for forging on the path less traveled. :slight_smile: