Error setThumbnailDataFromImage


#1

My Homepwner project is throwing an exception when I assign a photo using the imagePickerController. I have isolated the error to the line code in -(void)imagePickerController:(UIImagePickerController *)picker didFinishPickingMediaWithInfo:(NSDictionary *)info

[possession setThumbnailDataFromImage:image];

I tried stepping into the line, but the exception is thrown immediately. I never make it to -(void)setThumbnailDataFromImage:(UIImage *)image located in Possession.m.

Exception Details:
2012-03-10 10:04:01.110 Homepwner[10028:fb03] *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[NSManagedObject setThumbnailDataFromImage:]: unrecognized selector sent to instance 0x6b90630’

Tried re-building the Homepwner App from scratch twice in an attempt to make sure I did not overlooked something, but I get the same result. Can anyone help? I can comment out the line and every other aspect of the App works properly. Just no thumbnail displayed in the subview.