Gen Folder Generates Empty


#1

Hi I’m posting this topic to hopefully get some more eyes on this problem. I’ve been trying to figure this out for over a week, none of the solutions I’ve seen on the web seem to be working.

As soon as I create a new android project, there are two errors, both “R cannot be resolved to a variable.” A few of the solutions I’ve heard about that aren’t working:

  1. There are no other errors. Anywhere. Like I said, this happens AS SOON AS i open a new project.
  2. I’ve updated the SDK and ADT. and restarted everything.
  3. I don’t have any illegal characters in layout xml file name.
  4. I don’t have an import android.R line.
  5. I’ve tried to clean the project.
  6. I’ve tried to uncheck and recheck automatic build. And done a manual build.
  7. I’ve gone into Project Properties -> Java Build Path -> Order and Export and made sure Android Private Libraries is checked, and then cleaning and building.

Very much want to work through what looks like a great book for learning android programming, but my software won’t let me get past the first chapter! Very frustrating! I really really really appreciate any help!


#2

OK just deleted and re-downloaded eclipse and the sdk for the 3rd time, and it seems to be working now. Fingers crossed it’s fixed for good!


#3

I had a similar problem running on Ubuntu 13.04 64-bit.

I was working through the problem and tried cleaning the project so that it would rebuild (Project -> Clean…).

On doing this I got a different error with a ‘hint’ to install the ia32-libs package. After doing this and cleaning the project again, things seem to be working for me.