Grey screen when running( in simulator)?


#1

I’ve followed the instructions down to the T for the quiz app, and when I run it, I just get a blank gray screen! I did this example a few months ago and it worked no problem, but now that I’m trying to learn again, I’m getting this gray screen business. I even tried making my own other simple app and got the same problem! Maybe it’s an xcode problem?


#2

Would really appreciate some help. I can’t find any solutions, and I literally can’t progress without fixing this :confused:


#3

There isn’t really enough information to tell what’s going on here.

Try this: create a brand new project. Then build and run it immediately. Do you see a white screen? If so, that’s good. If not, I don’t know what to tell you - reinstall Xcode? (I’ve never heard of a gray screen… is your screen’s brightness low?)

Then, add the code back in and build and run whenever you can - making sure the screen doesn’t go to gray. When it does, you know where it went wrong, and you can post back here with the step that made it go gray.


#4

that’s an xcode problem - xcode 4 bug

start a new project with a lowercase name, and use the same code

Cheers :slight_smile: