headerView is not resizing


#1

Hi guys,

I’m not getting my headerView to resize, after implementing the toggle for editing bit.
I don’t know what I’m doing wrong… I’ve gone over the code and instructions more than once and I’ve compared the downloadable project to mine. Can’t seem to find what I’m dong wrong.

This is what it looks like in the XIB file…

…and here’s what it looks like in the simulator.

I just changed the background colour for debugging purposes


#2

I recreated the XIB file, etc and now it’s working.

:open_mouth: :question:

Gotta love programming!


#3

I had same problem, when I selected the header View in the canvas, the properties showed me full height of iphone screen although the view was showing small, I just typed in a number to make small height to match what I saw in canvas and it worked.


#4

perhaps you load the wrong XIB, I meet the same problem, and after several times check, I found I ues the wrong XIB file. after changing the file name, then all stuff have been solved.


#5

I had a similar problem with this in that my header wasn’t showing. It turned out I had selected “freeform” in the HeaderView’s View size dropdown in the “Simulated Metrics” section of the property inspector. Setting it to none resolved my problem. See Screenshot:

Xcode 4.6.3 iOS 6.1