Help creating BNRItem class


#1

Hi all,

New to a mac. I have Xcode 4.4 and Mac OS 10.7.4. I’m trying to follow the creation of the BNRItem class and I’m stuck. Following the instructions I finish the creation of the class without being given the selection of checking the randompossessions as a target. Then when I open the .h file it has:

#import <Cocoa/Cocoa.h>

instead of #import <Foundation/Foundation.h> :question:

I can’t seem to find any correction for this. Can someone help me out please. Thanks!


#2

When you created the project, you selected one of the Cocoa application templates, but you should have selected the Command Line Tool template in the Mac OS X:Application directory.

Start over again by creating a new project.


#3

FYI for those who might have the same issues later on.

OK, I figured out what I did wrong. When I was creating the new file for the class I did not have the random possessions project open, I probably closed it or something. Anyway after I opened the project, selected the new file to create then it worked the way it was suppose to.

Thanks!

Calwas thanks, but I figured out what the issue was.


#4

marriola,

Yeah, I discovered that same issue, I had closed mine out after a night of learning and then opened up again in the morning and started reading. I kept scratching my head figuring I was missing something really easy. Then I said the magic phrase “I wonder if…” and sure enough that’s what fixed it.

Came over here to see if anyone was having the same problem. Glad to know I am not alone.

I don’t think this is an error on the BNR side either, I just think for people like me, who are just getting into learning all of this, I make some assumptions that are OK and some that are wrong. I just like the fact that working through them gives me the results I am looking for.

Matt. :smiley: