Homepwner Problems in SDK 4.0


#1

I began completing Homepwner in a version of SDK 3. I recently downloaded SDK 4. I began Chapter 13, and opened the Homepwner project. I tried Building and Running it before I began any new code. There was one error and it said that the “Base SDK was missing”. This is because I worked on the project in SDK 3, and I am now trying to run it in SDK 4. How do I fix this problem? Is there any way I can salvage my work and find a way to convert the project to SDK 4 so it can correctly Run?

P.S. Thanks a lot. I’m a beginner, I apologize if this is a simple fix.


#2

Yes, you can salvage your work very easily. This is the first time I can remember Apple doing this, but they removed pre-3.2 SDKs from the developer tools. (They usually wait a few iterations before dropping support for the previous OS. Reading in between the lines: they want you on 4.0 and no where else.)

Go into the Project menu, select Edit Project Settings. Choose the Build tab. Find the “Base SDK” setting near the top, click the value box and a popup menu will appear. Choose iPhone Device 4.0 from this list.


#3

Thank you very much! It works perfectly now.