Method Does Not Show When Linking Button To File Owner


#1

Method Does Not Show When Linking Button To File Owner. Any help is appreciated!



#2

Assuming that you have saved the IB document file for the BNRDocument.

What is the Custom Class name of the File’s Owner?
Since the createNewItem: is declared in the BNRDocument class, File’s Owner’s class type should be BNRDocument.
Check this first and correct if necessary.


#3

Hmmmmm. Didn’t say anything in the book about that. But that fixed my problem. Class Was Blank so i just added BNRDocument and now it works.


#4

thanks a lot, i had the very same problem!


#5

I am having this same issue. When I control click on my button and drag to file’s owner, the option createNewItem does not show. I see the instructions on this posting to change the class but I don’t see how do that. The book doesn’t seem to show this.


#6

In IB, select the File’s Owner; then in the inspector, change the custom class to your class.


#7

Yes, thank you. That solved that problem.


#8

I had a similar problem, this solution cleared it up, Thanks.