Need help, emulator doesnt run


#1

I just got this book, and already, I cant get my emulator to work. This is not exclusive to Big Nerd Ranch, since even the default helloworld wont run… I get the following in my console box… If you replace HelloWorld with GeoQuiz its the exact same output.

[2013-12-18 13:17:40 - HelloWorld] ------------------------------
[2013-12-18 13:17:40 - HelloWorld] Android Launch!
[2013-12-18 13:17:40 - HelloWorld] adb is running normally.
[2013-12-18 13:17:40 - HelloWorld] Performing com.example.helloworld.HelloActivity activity launch
[2013-12-18 13:17:40 - HelloWorld] Automatic Target Mode: launching new emulator with compatible AVD ‘Nexus_API_17’
[2013-12-18 13:17:40 - HelloWorld] Launching a new emulator with Virtual Device ‘Nexus_API_17’
[2013-12-18 13:17:56 - Emulator] creating window 0 0 577 1025
[2013-12-18 13:17:56 - Emulator] eglMakeCurrent failed
[2013-12-18 13:18:23 - Emulator] eglMakeCurrent failed
[2013-12-18 13:18:23 - Emulator] FrameBuffer::post eglMakeCurrent failed
[2013-12-18 13:18:24 - Emulator] eglMakeCurrent failed
[2013-12-18 13:18:24 - Emulator] FrameBuffer::post eglMakeCurrent failed

I have tried redownloading eclipse, I have tried both 32 and 64 bit versions. I have tried making the emulator different rams, different phones, different sdk versions. I have tried running as admin as well. I am out of ideas on what I can do…


#2

I spent some time on page 25 myself. I found that I had to add “200” MiB to the SD Card Size to make things work on my end. I searched the web for all of my error messages and found this suggestion that worked for me.