No information in debug area


#1

Hello! Wondering if anyone is having this same problem (and I’m a newbie, so I hope this isn’t a stupid fix!)

I have worked through the chapter and completed the bronze challenge. As you probably know, you are required to build and/or run the program at various points during the chapter so you can see what different output looks like.

After completing the bronze challenge and trying to remove my error (to ask for the 11th item), now when I build and run my program I get a “build succeeded” message (the little square message that pops up in the center of the screen), however there is no output in the debug error. It’s as if the program worked the first few times I ran it and suddenly stopped giving me any output. I am receiving no warning or error messages in my code, and I do have log message to spit out an item.

I have gone through and retyped the code from the entire chapter into a new xcode project, and similarly the program ran fine, but after running twice or so it stopped outputting any information.

Any help/suggestions/etc? Anyone seen this before? This actually happened once before during another challenge I worked on a few weeks ago from the Objective C book, but assumed it was my own mistake and eventually just gave up.


#2

Try creating a clean build. You can find that under product.