No Luck at All


#1

So I was happily on my way through Chapter 4 with Lion and XCode 4.2. Managed to kludge together a template and Whereami was working with one cryptic message at the beginning of execution, but the simulator seemed to work OK. There were obvious differences in what the book thought I should be seeing, so after reading these threads, I decided to downgrade to XCode 4.1. Got 4.2 uninstalled and after battling the iTunes bug, got 4.1 installed.

I went ahead and used the downloaded version of Whereami as a test. Nothing - simulator would not request permission for location services. Added the TemporaryHack - still nothing, compiled with no errors, simulator fired up, but no request for location services.

I’m at a bit of a loss on how to continue. At least the thing was executing with 4.2. Am I missing something?


#2

Well, went back to XCode 4.2 and used the Single View Application template. Seemed to work fine for this chapter by putting the code in analogous places. Executed with no errrors. I see some potential problems in Chapter Five, however.


#3

Hi,

I’m also running on 4.2 and using the iphone simulator. Could you please post your code as i’m having problems and can’t seem to get the coordinates on the console.

Thanks,

Faisal


#4

I would like to know as well. I am using the Single View Application template. I tried putting the code in the both the Delegate class and the Controller class and have also tried making both of them Delegates for the location manager. I am having no luck at getting it to work. It looks like locationManager:didUpdateToLocation:fromLocation: never gets called. I have tried this both on the iPhone simulator and on my iPod touch.


#5

Please see this post: viewtopic.php?f=74&t=3336