No zoom, with "warning: Unable to read symbols for..."


#1

I’ve entered all the code for WhereAmI up to page 80. When I build & run it on my device or on the simulator, it adds a pin but does not zoom to the marked location. I’ve added an NSLog statement to mapView:didAddAnnotationViews: but it never displays, so the method is apparently not getting called.

The console gives me this message:

[quote]warning: Unable to read symbols for /Developer/Platforms/iPhoneOS.platform/DeviceSupport/4.2.1 (8C148)/Symbols/usr/lib/info/dns.so (file not found).
2011-01-16 03:34:13.841 Whereami[1739:307] User location view is NOT visible but should be. Showing…
[/quote]

I’ve also noticed that my iPad is running iOS 4.2.1, but Xcode sees iOS 4.2 as the latest version. Do I need to somehow specify that I’m building for 4.2.1? I’m using Xcode 3.2.5.


#2

Look thru the posts below you will find the code.

The add annotation does not get called.


#3

My app was running fine until I restarted my mac… now I’m receiving the same error you are and my app wont zoom to my location. I tried copying the missing directory and file over, and that eliminated the error but the app isn’t functioning correctly.