Not displaying title and continues to Load


#1

Hi,

I have completed the project and it builds successfully, however both on the iOS 4.3 simulator and my iphone OS 4.3, I’m not being able to get my application to show me the title when i enter it in the textfield. It continues to load and seems like it remains in the [self findLocation] message.

I’m using the following developer settings: iPhone OS 4.3, Mac OS X 10.6, Xcode 4.0.2, SDKs 10.6

Here is the log:

GNU gdb 6.3.50-20050815 (Apple version gdb-1518) (Sat Feb 12 02:56:02 UTC 2011) Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "--host=x86_64-apple-darwin --target=arm-apple-darwin".tty /dev/ttys000 target remote-mobile /tmp/.XcodeGDBRemote-9662-32 Switching to remote-macosx protocol mem 0x1000 0x3fffffff cache mem 0x40000000 0xffffffff none mem 0x00000000 0x0fff none [Switching to process 11779 thread 0x0] [Switching to process 11779 thread 0x0] /SourceCache/GoogleMobileMaps/GoogleMobileMaps-263.5.2/googlenav/mac/Loader.mm:172 Incorrect protocol version. We got 15464, but were expecting 14. 2011-07-15 16:23:21.452 Whereami[1023:707] New location: <+43.04211644, -76.13501730> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:23:21 PM Eastern Daylight Time 2011-07-15 16:23:21.468 Whereami[1023:707] New location: <+43.04211644, -76.13501730> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:23:21 PM Eastern Daylight Time 2011-07-15 16:23:22.422 Whereami[1023:707] New location: <+43.04211644, -76.13501730> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:23:22 PM Eastern Daylight Time 2011-07-15 16:23:23.438 Whereami[1023:707] New location: <+43.04211644, -76.13501730> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:23:23 PM Eastern Daylight Time 2011-07-15 16:51:38.423 Whereami[1023:707] New location: <+43.04218619, -76.13501680> +/- 5.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:51:38 PM Eastern Daylight Time 2011-07-15 16:51:39.426 Whereami[1023:707] New location: <+43.04218619, -76.13501680> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:51:39 PM Eastern Daylight Time 2011-07-15 16:51:40.424 Whereami[1023:707] New location: <+43.04218619, -76.13501680> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:51:40 PM Eastern Daylight Time 2011-07-15 16:51:41.425 Whereami[1023:707] New location: <+43.04218619, -76.13501680> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:51:41 PM Eastern Daylight Time 2011-07-15 16:51:42.423 Whereami[1023:707] New location: <+43.04218619, -76.13501680> +/- 10.00m (speed 0.00 mps / course -1.00) @ 7/15/11 4:51:42 PM Eastern Daylight Time

This is just part of the log. It basically keeps finding new location. Can anyone let me know how to go about solving this issue. I’m a newbie so can anyone give me tips on how to debug this issue and how to approach it. Thanks.

Arti


#2

I’m new to iOS development, but did you double check your code where you defined and used the “title” field (from page 113 in the book)? I would look at the bottom of that page where it goes through setting up "MapPoint *mp = [[MapPoint alloc] initWithCoordinate:coord title:[locationTitleField text]];

Run the code through the debugger to see if you can find where its gone wrong.