Preprocessor Macros Build Settings Problem


#1

I tried to add the VIEW_DEBUG macros into the preprocessor as is instructed in the book, but when I did that my build failed.
I tried to restore it to the original setting without success, so I made a new Project and transfer the touchTracker code to the new project. I tried to run it before changing the macro and it works, but this time when I try to add the VIEW_DEBUG, nothing changes (the VIEW_DEBUG did not even appear in the table after I exited the popup table); however, when I try to build , it failed again!

This is the error I got the second time, the error the first time looks the same with the exception that there is also "clang: error: no such file or directory: ‘VIEW_DEBUG’ " in it.

clang: error: no such file or directory: 'DEBUG=1' Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1


#2

I’ve received the following error on the last exercise in the chapter:

I’m running Xcode Version 4.3.3 (4E3002). I followed some of the solutions online (i.e., delete DEBUG setting in “Preprocessor Macros Not Used In Precompiled Headers”) to no avail.


#3

Same Xcode version here.