Replacing the switch statement


On pg 352 when we implement the changeMapType method we use a switch statement.

Why not just use one line instead?


That’s a good question.

When adding the segment was a challenge, that’s how I implemented it…


It is possible we might re-map those values later, but yes, that works.