Running new app on my Motorola Android Phone


#1

I ran into an issue with my android phone. I plugged it in and noticed that the motorola phone did not show up on the Android Virtual Device Manager. I then checked the Run Configuration and selected “Launch on all compatible devices” and selected “Active Devices”. When I ran it, it loaded onto my divice the way it was supposed to. When I ran the program on my device before, I was able to select the actual device on the Android Virtual Device Manager. I recently made updates to my eclypse and wondered if that could be the reason why this happened. I was wondering if anyone else ever ran into this issue.


#2

The AVD manager is only for displaying emulators, so it will never show up there. I assume that you’re talking about the Devices pane in DDMS?

It’s not uncommon for devices to fail to appear there, though. The usual fix is to reset ADB. I believe the Debugging chapter gives instructions on how to do this.


#3

Phillips,

Thanks. I’ll keep that in mind. I did reset the adt and it still didn’t show. It only worked after I made the above specific changes. The good news is that I really feel that I’m learning something. I’m beginning to gain more confidence with this as I make things work. I love your book:)


#4

Glad to hear it! (and thank you!)