Time profiler not matching up


#1

My Time Profiler looks nothing like the one in Figure 21.1.7 on pg 388.

I search mach_msg_trap and it’s not showing up. Any ideas what I’m doing wrong?


#2

Same issue for me. Both on the simulator and the device.


#3

Instruments is flaky like that. Sometimes it automatically prunes out symbols (depending on the various options for each Instrument). You can try fiddling with the options on the left panel, but really the take-away here is to see items on this list move around as you do things in the application.

I suggest you build to the device, and keep the Instruments app open on your Mac. Then keep drawing a bunch of lines, and watch the Samples table change. As you continue to draw lines, you should see some functions move towards the top of the list. These are the functions that are wasting a lot of time while drawing.


#4

The only way I could find mach_msg_trap was to select the “Invert Call Tree” setting on the left side of the window.


#5

Clicking ‘Invert Call Tree’ made my UI look much more like the book. Probably an Xcode 4.3 thing or other update? I know installing from the App Store instead of a dedicated binary causes weird settings issues.


#6

yepp clicking invert call tree worked for me too :slight_smile: