Unsupported template dependency?


#1

I just got this book. Very excited about learning this. Downloaded and setup adt-bundle-mac-x86_64-20130911 on a MacBook Air with the latest version of the latest OS. Got to the last step of the setting up the GeoQuiz project and got this message.

Unsupported template dependency: Upgrade your Android Eclipse plugin

Then more about how this template depends on the Android Support Library and that the Required version: … and the Installed version: 18. Yes it is comparing my installed version against an empty value.

I tried clicking on Install/Upgrade, with nada response. I fired up the SKD Manager via Terminal. It shows version 18 installed like you would expect.

What to do?

Any ideas?

Thanks, Alex


#2

I ran into the same thing. Apparently it’s a bug in the latest version of the Android developer tools. It’s been reported to the Android Open Source Project, and there’s a discussion of possible workarounds:

code.google.com/p/android/issue … l?id=60149


#3

Thank you very much for your reply. I will check out the discussion on workarounds.


#4

The short story of the solution is that the version of Android/Eclipse that I download contained a bug and the fix was to download the SDK separately and replace the tools folder in the original download. Now it’s all good.