Xcode 4.3.1 / can't find Autosizing feature


#1

Hello, guys!
In the page 196 at fig. 28.7, I can’t find autosizing mask.
I’m using Xcode 4.3.1.
That feature gone?
Thanks in advance!


#2

It looks like Auto Layout is now turned on by default for the latest versions of Xcode 4.x. The good news is that you can easily turn it off and bring back the autosizing mask.

To do so:
[ol][li]Select the BNRDocument.xib file from the list on the left-side of the Xcode screen (Navigation Area)[/li]
[li]Show the File Inspector --click on the tiny icon that looks like a document on the upper right-side of the Xcode screen (Utility Area)[/li]
[li]Uncheck the box labeled as Use Auto Layout[/li]
[li]Save your BNRDocument.xib file[/li]
[li]Re-select the scroll view as instructed in the book[/li]
[li]Show the Size Inspector; it will now look like the example in Figure 28.7 in the book[/li][/ol]

—> Kelsey McClanahan


#3

For me, this fix activated the “struts” but the “springs” won’t activate…

Another option somewhere?


#4

Thanks! I’m on Xcode 4.3.2 and these instructions worked like a charm.

@Mark9989: Did you get this resolved? So what exactly happens when you click the lines on the springs and struts?


#5

Observed same issue in Xcode 4.5.2. Got it to work by:

  1. BNRDocument.xib > File Inspector > Use Auto Layout > uncheck (off).
  2. Save file.
  3. Select another file in the project.
  4. Select BNRDocument.xib.
  5. Size Inspector > individually click on the arrows/springs.

#6

[quote=“ronkoan”]Observed same issue in Xcode 4.5.2. Got it to work by:

  1. BNRDocument.xib > File Inspector > Use Auto Layout > uncheck (off).
  2. Save file.
  3. Select another file in the project.
  4. Select BNRDocument.xib.
  5. Size Inspector > individually click on the arrows/springs.[/quote]

Perfect! Worked like a charm… thought I was losing my mind.

Thanks,
-Ron


#7

Since with the new updates of Xcode, the new Auto size check box. Does that basically just do it for you then? Do I still need to do this?