XCODE 4.5 : Impossible to run app for IOS 5.x


#1

Hello,

I used xcode 4.3.3 on Lion.
For this version there is not problem at running ios app for IOS 5.x and below

Then I installed the last xcode 4.5
And for this version I’m not able to run an ios app for IOS < 6 (as 5.1, 5.0 and below)

For example, take the first app of the book. Try to run it in OS simulator for IOS 5.1 and I have a crash when it opens in the simulator !!!
Not a lot of information, just a lld pbm apparently

I tried alot of tweaks, as removing the autolayout and set the deployment target for IOS 5.1 in the xib editor + target, but nothing to do. The app compile without pbm but can’t be run in 5.1 IOS simulator (in fact any < 6)

Ok so do you know how to be able to have an app running both for 6 and below ?
How to make the first easy app running on 5.1 with xcode 4.5 ?

Thanks by advance for your help
Pascal


#2

Once you’ve updated your iOS SDK, you can’t link to a previous version of the SDK. One thing you can do, though, is to change the deployment target of the application. In the Summary pane of the target, change deployment target to 5.1.


#3

I would like to know if there is a newer book than the Big Nerd Ranch Guide 3rd edition. I’m so new to iOS programming that I can’t take the time to troubleshoot the differences in the code versions. I simply need a new book that works with Xcode 4.5 so I can focus on learning the actual content. Any advice would be appreciated because I’m stuck in Chapter 8 and getting nowhere fast.


#4

As far as I am aware - the 3rd edition is the latest edition in this series.

If I were you - I would just download the older version on Xcode and redo the book.

Regards
R.