[xcode 4.5] IOS 5.1 emul problem


#1

Hello,

xcode : 4.5
OS : Lion 10.7.5

When I run the code from the first 1st chapter it runs without problem for IOS6
But If I run it for IOS5 I have an exception when it opens in the simulator (compile ok).

I’ve removed the autolayout for the xib file, and set the wib and all deployment to 5.1

If I run the exactly same code under Xcode 4.3.3 and for iOS 5.1 it’s ok

Do you know why ?
What I have to do to develop for ios5 from Xcode 4.5 ?

yet I’ll keep my old Xcode 4.3.3 until I find help to resolve this big problem

Thanks by advance for your help


#2

I’m new to this as well. I say new, I’ve done a few videos and a couple of books. So I tried to target 5.1 as well and got an error.

So I Gooled it. http://stackoverflow.com/questions/11198981/presentviewcontroller-crash

I turned off Use Autolayout and it works fine now.