Xcode 6*


#1

I started to learn programming through your book and I was immediately faced with a lot of problems. Current version of Xcode is 6.0.1. But the book was written for Xcode 5.*
The first problem that I encountered is the lack of a template “Empty Application”. I tried to make as it is written here in the last topic: viewtopic.php?f=481&t=9215
But perhaps, this led to incorrect display of the application in the simulator. Buttons and headers will not fit in the display. The new version also lacks the field “Class Prefix”.

I am newbie to programming and i can not solve it yourself. Could you give advice on how to go training by your book using Xcode 6.0.1?
Please help!


#2

Hopefully this will help?

gist.github.com/Whelton/7bb47fdce72ae278bdb4


#3

Hi,
I tried this and, unfortunately, it didn’t work. Do you have any other ideas?
Thanks


#4

Try this thread


#5

Hi,
Thanks for your help, I’m not sure what is meant by the GroupName on this link. I was able to download the template, but, I’m not quite sure what to do with them. I’ve been in cryogenic freeze since December, which is when I got my last Xcode update.
Thanks


#6

Then you lost me.

The current Xcode 6.0.1 – referenced in the original post – was released out of beta just days ago, which is a whole lot more recent than December.

So I’ll assume you really do have Xcode 6.0.1, and go from there. What follows is a variation on this thread, just to reduce the typing.

[ol]
[li] I assume:
[list=a]
[] you’ve already downloaded and unzipped the Empty Application template
[/li][li] Xcode is installed in /Applications
[/li][li] Xcode is not running when you perform the following
[/li][/ol][/
:m]
[li] In the Finder, control-click on the Xcode app, and select “Show Package Contents”[/li]
[li] Navigate to:
Contents

Developer
Platforms
iPhoneOS.platform
Developer
Library
Xcode
Templates
Project Templates
iOS
Application[/li]
[li] Drag the Empty Application.xctemplate folder to the Application directory above[/li][/list:o]
Launch Xcode and choose File > New > Project… > iOS > Application
You should now see Empty Application as one of the choices.


#7

Hi,
Thanks, I can see and create an Empty Application, however, (and I apologize, I hate however in these kinds of forums) here’s my current rub. I create an Empty Application and subclass an NSObject, like so:

#import <Foundation/Foundation.h>

@interface MYInterface : NSObject

@property (nonatomic) CGPoint pointA;

@end

it doesn’t like the CGPoint.
Not trying to be a bother, but, what is the issue with this?
Thanks


#8

Hard to say; works for me…though I don’t recall having to use CGPoint in chapter 1.

Incidentally…Christian Keur has provided a really helpful post on how to adapt the book to use Xcode 6.