Xcode wants a ;


#1

Right so I’m right at the end of the chapter. I noticed this error but finished typing up the rest of it. In WhereAmiViewController.m I have the line

It wants a ; at the end. I’ve checked ViewController.h. BNRMapPoint.h and .m. I can’t find where this error would be coming from. The only other thing is in ViewController.m I have an incomplete implementation warning most likely resulting from this error. I’ve tried deleting that line and the block of code following it the { } and retyping it but the same error appeared. Anyone else have this problem?


#2

From what I’ve seen, an incomplete implementation error means you declared a method in your header file and never implemented the method. I would guess that most likely you have a difference in the actual method name and it’s parameters.

Also while the method you specified is in the .m file, it’s possible that you may have placed it in the @interface section, instead of @implementation, which is essentially declaring that method as part of your header again.


#3

When I have a chance I’ll go through it all again and see if I put something in the wrong file.


#4

If you post both the header and main file, we can help out as well.