"You do not have access..." message


#1

When looking at documentation in the Organizer if I search, for example, for NSArray I get two of them in the results. The first one gives me a message that says “You do not have access to this resource based on your membership.” The second one shows the NSArray Class Reference without a problem.

I do have an Apple ID on Apple’s Dev Center but I haven’t registered for any paid programs. But from the Dev Center I can search for NSArray and the reference comes up with no problem.

Any ideas why I’m getting the two results in the Organizer?


#2

Not sure, but the two results are from iOS and Mac, so I’d see which one is coming up for you, and verify that you can log into the other one’s dev center via the web. It may be necessary to “register” with each one, even using the same Apple ID.


#3

From the Dev Center I can search for NSArray from both the MacOS part and the iOS part without a problem.

Here’s another clue. I turned off wifi to see what would happen. I get the same result list but when I click on them I get an error message that contains the url.

The first one is: developer.apple.com/library/pre … cl/NSArray

The second one is: developer.apple.com/library/mac … cl/NSArray

They are different. The first one has “prerelease” in the url. I get the same results (an error message with the first url and the expected result with the second) when I paste those urls into Safari. I looked around in XCode’s preferences and I don’t see anywhere to specify where to look for documentation.

Btw, I thought I had downloaded the documentation as per the Downloads pane of XCode’s preferences but I just checked and it didn’t. It seems to be downloading now (there are progress bars) so I will update this post when the downloads are complete. Perhaps XCode won’t look on the web if the documentation is installed locally.


#4

With the documentation installed I still get two results for NSArray. Now both work whether wifi is on or not (makes sense since they are installed).

And now I see why I get two results. The Jump Bar shows that the first one is from the iOS 5.0 Library and the second is from the Mac OS X 10.7 Core Library.

So the solution seems to be make sure the documentation is installed. Still, I would like to know why XCode, prior to installing the documentation, wanted to go to that prerelease documentation.


#5

Did you perchance download a prerelease copy of Xcode at some point?


#6

Not that I recall.


#7

I am not a registered developer and I have installed Xcode (4.2 + Lion) out of the App-Store -
I never had an issue like this, does your preferences look like this ?:

If nothing helps, I would uninstall Xcode (a backup may be a good idea) and then do a fresh install.


#8

I’m seeing the same issue. It will let me see the “online” documentation for Mac OSX, but gives me the restricted access error when looking at NSArray for iOS. I’m downloading the documentation now to see if it will allow me to see all of it.

The issue might be that XCode defaults to the most current revision of the documentation when it’s viewing it over the internet, which might be a pre-release version of the docs, and thus restricted to Developer Program users. If you download it into XCode, it might not be the “pre-release” version of the docs. Just a thought.


#9

I am getting the same “You do not have access” message. I would like to verify a few things just to be clear.
I remember not have to pay anything when signing up a Apple Developer. I was under the impression that if you didn’t pay the $99 fee, you could do anything except run a program on an actual iOS device or submit an app to the Apple App Store. I assumed I had full access to everything else including building and running apps on the simulators.

I’m I correct? Is this the difference between the free and paid memberships? Has anything changed? Am I getting a “You do not have access…” message because I’m not a paying member? - If so, was this always the case or has something changed? If it had changed, when and why did it change? Thanks :slight_smile:


#10

I believe you are correct. Nothing has changed. But, in order to access the documentation, for some reason you have to download it into XCode from the Preferences. It won’t access it “on-the-fly” over the internet. Once downloaded, then it will access fine. Not sure why that is.


#11

If you already have the documentation installed and are getting this message, it is because the documentation that first shipped was pre-release, but the Base URL for the documentation library was not changed when iOS was released. I fixed this by just removing the library and reinstalling it, since the updater doesn’t seem to catch this difference.


#12

Why after downloading the documentation it is still not showing up in the Organizer window?