Could not find method databinding()

Okay, I don’t mean to be hostile. But this is the third time I’ve tried this chapter and nothing is working. As far as I can tell, no matter what I do, the necessary databinding class is not getting created. This is why I hate relying on things to be generated “automagically…” Half the time, it doesn’t work. This is the error I get, every time…

Error(20, 0) Could not find method databinding() for arguments [build_bo1htpuh4qqa3ches1ynv4mew$_run_closure1$_closure5@2bff3f8a] on object of type

I’ve tried going by the steps exactly as described in the book, up through Listing 20.6. That didn’t work. I also tried starting over. Then cleaning and rebuilding after Listing 20.5. Nothing works. No matter what I do, I can’t get the databinding class to get generated. Could someone please tell me what I need to do to get this damn, magical unicorn class to get generated?

Nevermind, I figured it out. I had databinding instead of dataBinding in my gradle! God, what a flipping PIA!

1 Like