Customizing Code Snippets Problem


#1

I have 3 different Macs I use and have created user code snippets successfully on all 3. This morning, am trying to create one on my laptop. I create the snippet and drag it to the snippets area. The green add button shows up but when I release the mouse button (used the touch pad too, same issue) the snippet doesn’t ‘go into’ the library. It just sits there w/the green button. I have to hit escape a few times to dispatch it. Have added snippets here before. Tried restarting Xcode, etc. Any ideas what is wrong?


#2

Answering my own question. Came back several hours after initial problem occurred and was going to shut down Xcode but it was going through some self-updates, and would not let me close it. I waited for the updates to finish and then noticed that all the snippets I had tried to add were now in the snippets library. Evidently, when going through software updates, Xcode will not let you add snippets till the updates are done. Hope this helps someone in the future. It was driving me nuts.