Emulator error - application fails

After copying the GeoQuiz and naming it GeoQuiz Challenge, I tried just running this challenge in the emulator, but I get this error:
Installation failed with message Failed to finalize session : INSTALL_FAILED_INVALID_APK

Rerunning GeoQuiz, and it runs fine. As this is the 1st Challenge, I should get this resolved. I tried stopping the emulator, wiping user data, and starting again - same problem.

I’d try cleaning your project and re-running. Go to Build -> Clean Project and see if that fixes the problem.

1 Like

That did it – now I can go back and forth between projects, and the emulator behaves properly. Thanks (don’t know what “dirtied” the copy version) - Joe

Go to Settings > Applications. Probably you have the app still installed for other users (I had the same problem with a Moto G, I did not see the app among other apps, but it still was among my apps in Settings). Try to find it and remove for all users.

If the problem is this one you will find the app at the end of the list (in Settings > Apps > All)

All the apps marked as “Not installed” are still there and you can not install the same apps with Android Studio until they are there


This happens when your app is using any library and there is also an app installed in your device that is using the same library. Go to gradle and type:

defaultConfig.applicationId=“your package”
this will resolve your problem

Ethan Stark