Errors installing browser-sync with Node.js 10.16.0

When I try to install browser-sync using this command, I get a lot of errors.
I had no errors installing node.js, however. Is there something I need to do to fix this, or is it OK? When I run browser-sync --version I get this:
browser-sync --version
2.26.7

Thanks!

sudo npm install -g browser-sync

/Users/davidrosenbaum/npm/bin/browser-sync -> /Users/davidrosenbaum/npm/lib/node_modules/browser-sync/dist/bin.js

fsevents@1.2.9 install /Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents

node install

node-pre-gyp WARN Using needle for node-pre-gyp https download

node-pre-gyp WARN Pre-built binaries not installable for fsevents@1.2.9 and node@10.16.0 (node-v64 ABI, unknown) (falling back to source compile with node-gyp)

node-pre-gyp WARN Hit error EACCES: permission denied, mkdir ‘/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/lib’

gyp WARN EACCES user “root” does not have permission to access the dev dir “/Users/davidrosenbaum/.node-gyp/10.16.0”

gyp WARN EACCES attempting to reinstall using temporary dev dir “/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/.node-gyp”

gyp WARN install got an error, rolling back install

gyp WARN install got an error, rolling back install

gyp ERR! configure error

gyp ERR! stack Error: EACCES: permission denied, mkdir ‘/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/.node-gyp’

gyp ERR! System Darwin 18.6.0

gyp ERR! command “/usr/local/bin/node” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “configure” “–fallback-to-build” “–module=/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64/fse.node” “–module_name=fse” “–module_path=/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64” “–napi_version=4” “–node_abi_napi=napi” “–napi_build_version=0” “–node_napi_label=node-v64”

gyp ERR! cwd /Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents

gyp ERR! node -v v10.16.0

gyp ERR! node-gyp -v v3.8.0

gyp ERR! not ok

node-pre-gyp ERR! build error

node-pre-gyp ERR! stack Error: Failed to execute ‘/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64/fse.node --module_name=fse --module_path=/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64 --napi_version=4 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v64’ (1)

node-pre-gyp ERR! stack at ChildProcess. (/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/node_modules/node-pre-gyp/lib/util/compile.js:83:29)

node-pre-gyp ERR! stack at ChildProcess.emit (events.js:198:13)

node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:982:16)

node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)

node-pre-gyp ERR! System Darwin 18.6.0

node-pre-gyp ERR! command “/usr/local/bin/node” “/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp” “install” “–fallback-to-build”

node-pre-gyp ERR! cwd /Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents

node-pre-gyp ERR! node -v v10.16.0

node-pre-gyp ERR! node-pre-gyp -v v0.12.0

node-pre-gyp ERR! not ok

Failed to execute ‘/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64/fse.node --module_name=fse --module_path=/Users/davidrosenbaum/npm/lib/node_modules/browser-sync/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64 --napi_version=4 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v64’ (1)

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/browser-sync/node_modules/fsevents):

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 install: node install

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

  • browser-sync@2.26.7

added 316 packages from 261 contributors in 16.861s