Anyone else have capitalisation issues in 10.8 and xcode4.4


#1

Hi folks

Since upgrading to ML and Xcode 4.4 the autocompletion keeps trying to capitalise first letter of words for me. I type “if” and get “If” , “self” becomes “Self” unless i tab to autocomplete in which case it will often do it right - its not just keywords having trouble with typing methods and ivars etc.

I’m struggling with learning iOS as it is , bugs creeping in due to this annoying capitalisation issue is slowing me down and making things harder.

As a note i have tried going into text and language systems preference and turning the automatic spell checking on or off makes no difference

Is any one else experiencing this and if you have , have you found a solution ?

Cheers

Simon


#2

I’m replying to myself here

I tracked down what was happening and its an issue with Text Expander that didnt exist prior to ML and Xcode 4.4 ( at least for me )

So if you are experiencing annoying capitalisation issues in Xcode and are running TextExpander I suggets you quit TextExpander and see if things get better for you.

If it did then there is an option in Text Expander’s Preferences - Options section that is capitalise new sentences. You can turn it off either globally or by excluding specific application - exclude Xcode and the issue goes away

Hope this helps anyone else out there that had this same issue


#3

Thank You! I was going mad looking for the solution to this in xCode…

All I had to do was set: “Correct Capitalization in all Applications Except… Xcode” in the TextExpander preferences and it fixed it.

Thanks again